Discussions

Ask a Question

Turing RK1 pin out

I noticed there is no documentation describing the pin out for the Turing RK1. There does not appear to be a datasheet describing the pin locations so I am not sure what pin out is being used. Would also be nice to get the pin out for the CM4 adapter as well.

What is the usecase for the dual NIC if they can't bond/aggregate?

I was wondering the intention of the dual NIC's in a switch. I understand we won't be able to bond them but can you address one to a compute module? Does it help if you have multiple boards to have one less hop between them by going direct? I am just wondering what potential use case for using both of them would be if we are limited to 1 GigE.

SD card not visibile on CM4 with 32 gb of flash memory

Hi everyone, I've a CM4 with 32gb of flash memory on it. I managed to flash ubuntu on it with BMC, when I insert the additional memory card it will not show as additional block device and I cannot use it. Do you have any advice?

Cannot flash Orin NX

Hi, I'm having a similar problem to <https://docs.turingpi.com/discuss/65769862f5b2170057024391> but didn't want to hijack that thread. BMC firmware 2.0.5 I have RK1 modules in slots 1-3 and a Jetson Orin NX in slot 4. All have 2Tb NVME drives. Having a lot of trouble flashing the Orin. I did start with a VM in Proxmox and a pass-through for the A-A cable but apparently that USB translation can't keep up... Currently, I'm using a spare laptop running 20.04, connected to the TPi board with the A-A cable. The Orin is set to Flash mode from the Web GUI and does show up as a USB device as detailed in the instructions. Jetson download is R36.2.0 That required amending the instructions for the sed to sed -i 's/cvb_eeprom_read_size = \<0x100>/cvb_eeprom_read_size = \<0x0>/g' Linux_for_Tegra/bootloader/generic/BCT/tegra234-mb2-bct-misc-p3767-0000.dts after then, what looks like it is working 9vbuilding stuff), as there are system notifications about mounting (what seems to be) the nvme drive during this: sudo bash -x ./tools/kernel_flash/l4t_initrd_flash.sh --external-device nvme0n1p1 -c tools/kernel_flash/flash_l4t_nvme.xml -S 900GiB --external-only --showlogs --network usb0 jetson-agx-orin-devkit nvme0n1p1 but ends with ... [ 0.1879 ] tegrarcm_v2 --instance 3-1 --chip 0x23 0 --pollbl --download bct_mem mem_rcm_sigheader.bct.encrypt --download blob blob.bin [ 0.1885 ] BL: version 1.4.0.1-t234-54845784-08e631ca last_boot_error: 0 [ 0.3389 ] Sending bct_mem [ 0.3553 ] Sending blob [ 3.5802 ] ERROR: might be timeout in USB write. Error: Return value 3 Command tegrarcm_v2 --instance 3-1 --chip 0x23 0 --pollbl --download bct_mem mem_rcm_sigheader.bct.encrypt --download blob blob.bin Cleaning up... The logfile for this can be seen here <https://www.dropbox.com/scl/fi/suz05832df07gqoj19hlq/20240228-orin-flash.out?rlkey=64tmt7e8ie0yb9mr92ttdwxwz&e=1&dl=0> Is it possible to build an image I can dd to the nvme drive ? or is that a question for the nvidia forums? and would the Orin require a bootloader flashed to it like the RK1 modules? (even when the system is on the nvme drive) Other than this, the other RK1 modules now running docker/portainer/GlusterFS are great :) Thanks, Sean

USB_OTG not working with mouse or keyboard on Jetson Nano in node 1

Hi, I have the turing pi 2 with BMC 2.0.5 firmware. I have a Jetson nano B01 in slot 1. The nano boots up fine and I see the screen on the hdmi at 1080p. I can watch the boot process but my keyboard and mouse do not work. I tried changing the port to device and back to host, no luck. I changed the usb port to node 2 then back to node 1 both in host mode. Am I doing something wrong or is this a bug I don't know about.

Firmware Upgrade from v1 to v2 not working

Hi! I am an early adopter of turingPi2 but the board was stored in a shelf until now :) So I got the very vanilla board without any firmware updated yet. So I assume I am on 1.x whatever. I read the documentation on how to update to v2. I prepared a micro SD card, shut off the board, inserted the sd card, booted and waited to start for the NIC leds to flash, well nothing happens though :(. When I connect the board to my network it gets an IP and runs from the microSD card with the new version. But I want to flash directly to the BMC. Do I need to follow an upgrade path? Like first go to v1.x and then to v2 ? I cannot even ssh into it on v1 because it is disabled according to the wiki. I have no possibility right now to connect via serial. Any hints? thanks Dan

Shipping by UPS? Or to a PO Box?

Sorry if this has been answered elsewhere. I live in a high-package-theft area of a big city. If I ship via UPS, it will be redirected from my street address to a UPS pickup point. Can I ship via UPS from TuringPi? Thanks!

Can all TP2 boards be flashed with BMC v2.0.5?

I tried flashing BMC v2.0.5 to my TP2 board. The process appeared to go correctly (Based on the LED signals), but now my board won't boot. I also tried booting directly from the SD card, but it still won't boot. I'm wondering if I need to use a different version, like 2.0.3 or 2.0.4? Anyone have any suggestions?

No connection to the board

Any good ideas on troubleshooting not seeing the board get an IP via DHCP? I powered up the board and have lights in the pico psu (blue) and 2 green diodes on the board, as well a yellow diode blinking next to the first slot. There's also light in the network port. I have tried both ports, multiple network cables, but no matter what the board it not turning up. I have removed all hardware, so it is now only the board.

RK1 Maximum VLANs?

I've successfully deployed both the official Turing firmware 5.10 and the Joshua 6.1 kernel version ubuntu images on my RK1 16GB nodes, but I've been unable to add more than 4 VLANs to the ethernet configuration without running into an error: ```text rk_gmac-dwmac fe1c0000.ethernet eth0: MAC_VLAN_Tag_Filter full (size: 4) ``` Is 4 the expected limit in the RK1 hardware? Anyone have a workaround? My google-fu hasn't been finding anything useful in terms of being able to run in promiscuous mode and use vlan filtering in software or anything like that. The ultimate goal is to get these running qemu/kvm with virt-manager in the same setup that I have on the two RPi CM4 nodes, across the multiple VLANs that my home network is split into, but falling at the first hurdle. \[ IoT, Trusted IoT, Servers, Management, Guest, AV, etc. ]. Thanks, Mark