Ask a Question

Pi OS Installed with Flash Node on BMC Version 2.0.5 - Login ? Password ?

This looked like a great option but the new Pi OS has no default login or password. Any guidance to logging in, or is this hopeless. Tried the rpiboot/tpi route with raspberry pi imager, but the tpi steps in the docs just throw errors. I also have doubts about the usb connection between the turing and pc. Any discord or other resources that have more guidance on this process. Thanks.

Xavier NX fan cable too small

Hello, I wonder how I can connect my Xavier NX fan to the board. The cable is clearly too small. I've tried to install the cooling system differently but I can't. Is there some cable extension I can buy somewhere ? or do I have to cut and solder extension myself ?

Flash CM4 in Turing Pi 2

I’ve updated the firmware to v1.1.0 <https://github.com/turing-machines/BMC-Firmware/releases/tag/1.1.0> Logged in via SSH Done this: <https://docs.turingpi.com/docs/raspberry-pi-cm4-install-os-using-turing-pi2-cluster> # tpi -u device -n 1 {"response":[{"result":"ok"}]}# # tpi -n 1 -l -f /mnt/sdcard/2023-10-10-raspios-bookworm-armhf-lite.img % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 100 73 0 73 0 0 24 0 --:--:-- 0:00:02 --:--:-- 24 # tpi -n 1 -m booting node 0 into msd mode. please wait a moment.. {"response":[{"result":"ok"}]}{"response":[{"result":"ok"}]}# mount /dev/sda1 /mnt/bootfs mount: mounting /dev/sda1 on /mnt/bootfs failed: No such file or directory # mount /dev/sda1 /mnt/bootfs mount: mounting /dev/sda1 on /mnt/bootfs failed: No such file or directory # mkdir /mnt/bootfs mkdir: can't create directory '/mnt/bootfs': File exists # mount /dev/sda1 /mnt/bootfs mount: mounting /dev/sda1 on /mnt/bootfs failed: No such file or directory Bootusb does also not work. I’ve connected it to my computer via USB-A to USB-A sudo ./rpiboot -l -d msd/ RPIBOOT: build-date Nov 15 2023 version 20221215~105525 f4a6d8b4 Loading: msd//bootcode.bin Loading: msd//bootcode4.bin Waiting for BCM2835/6/7/2711... I’ve tried this on Mac OS and Windows Do you have any suggestions to flash the CM4 Pi?

BMC 2.0

Curious when the BMC 2.0 update will go public - announced a few weeks ago but no updates since - hoping the upgrade path/procedures will be better than the wonky process required for V1.1.0 (which I still haven't been able to successfully install) - Ideal for me would be a SD Card process where image provided by the firm (no docker builds) can be automatically flashed (or at worst applied via TPI Serial/web pages) - the OTA, Phoenix, VirtualBox, ADB process in a word is terrible and for the most part does not work - documentation of the process leaves many steps out and is not clear - not to mention the grammar, spelling and backward/forward references - perhaps it's just me but I expect better for a commercial product. Don't get me wrong - I see the potential and I want to work through the issues and make this the product that was advertised at the start but becoming dejected at how hard this is and the roadblocks I keep encountering - maybe it's just me but I am a 30+ year IT professional with EE background/training.

TP2 2.5 - More updates please!!!

Hi - Supporter from the Kickstarter days - wondering when TP 2.5 will be available and if there will be an upgrade path for those of use on 2.4 - these changes sound very positive and would love to hear more. Richard

More Jetson Details

The Jetson details in the docs don't provide NVIDIA part numbers, so I'm wonder if that could be added so that the docs address questions like: Will this Jetson module work in the TP2? Manufacturer Part No: 900-13448-0020-000

When do we actually get what we pledged for

Hi, My order has been processing for over a month - when do you guys intend on sending

Print out documentation

Is there any way to print out the documentation?

Is Turing Pi V2 MAC address random?

I am running the original kickstarter firmware on my Turing Pi V2.4 with ethernet connected to the port closest to the HDMI port. I am using PiHole for DHCP and it seems that the Turing Pi is using a different MAC address each time. Is this by design and will v2 of the firmware have an option to disable this? Note this is only the case for the Turing Pi. The individual CM4 nodes I am using have the same MAC address each time they are booted.

Can't access BMC

Just plugged together my Turing Pi 2 from Kickstarter and I can't get access to BMC neither by USB (after installing the drivers) nor by IP. Trying both ethernet interfaces the device does not get an IP, link and activity are both almost constantly up, yet no IP is assigned. I have the CR2032 inserted, using the pico power supply, green lamp next to the power supply is constant green, I have no modules installed in 1-4, next to 1 an amber light is flashing in a complex pattern I have yet to decode. Any thoughts?