Ask a Question

Flashing CM4 with eMMC

I followed the instructions for flashing a CM4 with eMMC onboard. The flashing parts seemed to go as described but when I did the "tpi -m -n 2" command it comes back and says "booting node 1 into msd mode. please wait a moment.." The CM4 module that has the onboard eMMC is in the node 2 slot. Not sure if the bug is in reading the command line or what is printed out. Once I do the tpi command to boot node 2 into msd mode, I cannot mount the disk. Also, when I reboot the CM4 module in slot 2 it does not show up on the network. I was trying to isntall hypriot so it should have at least booted and gotten an IP address from DHCP. Looking for any advice. BTW... I also updated to the latest firmware on the TP2 board. It does not appear that anything was done to the CM4 in slot 1. That CM4 does not have onboard eMMC and is a K3S master and never goes down through the process. I put the CM4 with eMMC in just experiment with the idea of remote imaging so it is not breaking anything, I would just like to figure it out.

Ordered, not here yet

I ordered a turingpi in late July - it is Nov 3 2023 now - when will it be shipped?

Cant flash BMC

HI there, Running a 1st batch pre-order TP2, and getting to flashing BMC for the first time. But I seem to be struggling. Uploading 1.1 via the http I get either: 1. a complete stuck upload (OSX / Safari), or... 2. An access error: Internal server using Google/Firefox etc So I tried to SSH to it, but the root / Turing password combo is failing. Anyone else had this?

heatsink fan combo for CM4 using dedicated headers

I would prefer to find a CM4 heatsink & fan combo that attaches to the provided headers next to each slot on the TP2; anyone seen any?

Turing RK1 shipment

According to the information in my turingpi.com account, the shipment of the RK1 modules should start today. Is everything on schedule so far?

Orange Pi CM4

I am happy to report that I was able to add an orange pi cm 4 node to my Turing pi 2 using the supplied adapter boards. As far as I can tell everything is working. I know that the RPI CM4 doesn’t support the M2 NVME SSD boards on the bottom. Will this be the same for all CM 4 clones?

Problems with suspending boot process without connected USB device

I found some time to play around with the Turing Pi 2. I'm still missing the four CM4 modules I wanted, but I was able to use another system's CM4 temporarily for testing purposes. I have BMC 1.0.2, upgraded via OTA from 1.0.1 (?)). Assignment USB \<=> node1 = DEVICE works, I was able to flash the CM4's eMMC using a MacBook Air M1 connected by USB cable. The CM4 boots in all slots node 1-4 but only if a USB device is connected to the Turing Pi2, no matter if keyboard, mouse, or even USB flash drive. The assignment is of course USB \<=>node 1-4 = HOST. As soon as no USB device is connected, the boot process suspends, it continues immediately when any USB device is connected. But since I want to run the Turing Pi2 headless in a 19" rack I will not connect any USB device or HDMI to the board in the future.

Access Serial Console CM4

Hello @all, i have seen that it is possible to use the cli tool tpi to "get" and "set" over uart to a node. Is it also possible to make a bidirectional uart connection to the node to make an interactive session via "screen"? Thanks Frank

No serial console output on BMC UART3?

Hi, I'm a bit stumped and am hoping peeps here might be able to help me. I'm connecting to the BMC UART pins with a USB -> TTL Serial converter cable, and while the converter is reconised and I am able to successfully connect to the device using the "Serial" app on MacOS I am not recieving any output from the Turing Pi. I have tried different flow control options in the "Serial" app settings and have tried swapping the RX/TX cables around and restarting everything. I have been able to succcessfully flash the BMC firmware via the Micro USB port to version 1.1.0 following the guides and a Windows VM. The BMC starts up ok and after a short while I can access the web UI with no issues. The converter cable I am using is using the FTDI FT232RL chipset and I have installed the dedicated drivers for this chipset and confirmed that "Serial" app is using these drivers and not the Apple macOS drivers. When I press the BMC_RESET button I do see the following so \_something_ is recognising the reset has happened - but I suspect this is coming from the the FT232RL and not the BMC? ```text shell [Disconnected] [Connected] ``` I am also using the following: Serial v 2.0.16 macOS Sonoma 14.0 (23A344) Intel i9 2019 MacBook Pro Let me know if you need any other information. Thank you in advance for any tips or suggestions that can help me figure out what is going here.


Hello folks, Perhaps has it already been answered but is it possible with a turing pi2 cluster (4 rk1) to install a proxmox cluster on it ?