Ask a Question
Back to All

Accessing Turing Pi Webpage, and Updating BMC Firmware

Although I can access my Turing Pi using a USB cable, I can’t seem to access the webpage interface using a browser or PuTTY (See Below).

Using PuTTY:
“Unable to open connection to
Host does not exist”

Using Firefox:
[email protected]:22

“This address is restricted
This address uses a network port which is normally used for purposes other than Web browsing. Firefox has canceled the request for your protection.”

Using Firefox:
[email protected]

“Hmm. We’re having trouble finding that site.
We can’t connect to the server at turing.local.
If you entered the right address, you can:
Try again later
Check your network connection
Check that Firefox has permission to access the web (you might be connected but behind a firewall)”

Since my current BMC firmware version is not up to date (V1.0.0.7), I decided to update it, hoping the current version would address these issues. However, since I can’t access the webpage, I can’t perform an update OTA.

But when I tried updating using the Phoenix Suit software, I ran into another problem. Phoenix Suit doesn’t recognize the USB connection. The message is: “No Device Attached Yet”.

I thought that maybe I needed to reset the ADB daemon on the Turing board, so I logged in over the USB connection and tried the following commands;

adb kill-server

  • server not running *

adb start-server

adb devices

error: device offline

I am guessing that my inability to connect to Phoenix Suit has something to do with ADB, but I can’t figure out how to resolve it.

I would appreciate advice on any or all of the above.